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% TG Tutorial: Enrollment

About this Tutorial

This tutorial describes features and behaviors that define and influence the enrollment process
in Test Generator.

Beginning with TG2.4.16 r2012110700, the user management module GUI has been updated to
assist customers with the organization and enrollment of test takers across multiple courses and
tests. Information regarding the latest release is available here.

While this review is comprehensive, it does not cover every possible combination of settings that
test authors might attempt and welcome your comments and suggestions for improving this, or
any other TG tutorial we publish.

Thank You.

Your Test Generator Team
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Definitions

We've published a Test Generator Definitions page for your review. If you have questions, or simply

need a refresher regarding some of the elements, please visit this page, or contact us.

Test Takers

To take a test, an individual must have a user profile in TG’s database.
The user profile must include a User ID and a Password.

T.admins can create User profiles manually, or by importing them into TG’s database from a TG-friendly
.csv or .xIs file or by synching user profiles into TG’s database using our AD/LDAP plug-in.

User Type
Last Name:  |Bryden (" Administrator Send Email_.
- [Bil " Instructor
(Rl ‘ @ Test Taker
Middle: \

[~ Disable User (Use the View menu to show these users)

Internal ID: 113 [~ Disable Login

Scores Login I Personal ] Permisswons} Noles}

Use only letters and numbers for the User ID and Password. with no spaces

User ID: |
Current Password:

xxxxx

Blank Password? [~

New Password: |

[ user must change password at next logon

(Above: TG admin client display seen by t.admins)

User profiles include

e AScores table as well as Login and Personal (tab) settings.

e Permissions: t.takers privileges are restricted to taking tests

e Notes: optional memo field for use by t.admins

e Additional settings and behaviors described in more detail in TG Help.
e Passwords are encrypted and hashed.

2/18


https://www.testshop.com/test-generator-product-definitions
https://www.testshop.com/contact

% TG Tutorial: Enrollment

T.admins have the option of changing the t.taker’s User ID and Password settings.
T.admins can also require the t.taker to ‘change password at next logon.’
In addition, the web Tester login page can include a ‘Forgot...” option.

]

)\ Forgot passward/login? Click Here

TG Web customers can also request the creation of a registration form. The form would enable the
customer’s testing audience to self-register. Registration forms are customizable. For more details
please contact us for a free consultation.

User Organization

Best Practice

We recommend organizing t.takers into user folders. In the example below, t.takers are organized into
folders labeled Group-1, -2 and -3. User folders can represent a department, region, company or
whatever name you wish to apply. In this example of the older TG2.4.16 user interface, we’ve expanded

the Group-2 folder—each user is represented by a user icon displaying the t.taker’s Last and First name
as well as a primary ID.

=48 Users 4
®-[3 Instructors

=-E» Test Takers

-3 Group-1

B-F% Group-2

-¢h Bryden, Bill (123456782)
- Celeste, Zoe (123456787)
-&h Hamby, Patti MI (12345678
-&h Lyons, Asa (123456788)
B Group-3

E- Administrators

----- & My Account
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New User Interface

The new Users module organizes users into folders—users will no longer be visible in the tree view
under the root user directory. For example, members of the Test Takers user group will be organized
into folders and the members of that group will be visible in a table, as in this example.

Group-1 users are displayed on the right side of the screen.

G Test Generator

Eile Edit Tools View Help

NEEFTBASI | X | SOW @
o, =, | o
o ho | R
54 Ella Fain
&3 Courses and Tests USE I'S
- Reports
= Question Bank Move Selectad to Folder... | ’
=-6% Media Bank First Middle  |Last
o8 Users

guest1
guest2
guest3
guest4
guests

=[5 Instructors

£ Group-
Administrators
7 System

Editing a User Record: T.admins will be able to edit a user record by dbl-clicking on the user row in the
table. This action will launch the user’s profile window. The information and behaviors found here are
(currently) the same as the features and behaviors found in our current 2.4.16 user interface.

User - Test Taker

Last Mame: |9uest! [~ Disable User (Use the View menu to show these users)
First Name: |guest1 [~ Disable Login
Middle:

InternalID: 90

Scores ‘ Logm} Personal \ Perm\sswons} Noles]

Test [ Date Taken | Score % | Attempt

Refresh | Delete |

Send Email.... Cancel Delete User
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Custom User Fields: One related, and important, feature that is often overlooked is the Custom User
Fields setting found under TG’s System module: Settings: User Fields. In addition to the default fields
found under the Personal tab, t.admins can customize additional fields. These fields are then displayed
in a column to the right of the default fields. Up to 10 custom fields can be added.

For more information regarding potential applications, please contact us.

User - Test Taker
LastName: |Lyons |~ Disable User (Use the View menu to show these users)
First Name:  |[Asa [~ Disable Login
Middle:
IntemalD: 119
Scores ] Login ; Personal } Permissions } Notes ]
Address Line 1: |1 22 Carter 5t Department I
Address Line 2: | Manager I
City: ,W Mgr Email I
State / Province: |GA
Zip / Postal: ’W
Country: | ﬂ
Phone: ,W
Company Name: |
Primary ID: ,W
Secondary ID: ,7
Email Address: |a@org com
Gender: ’—Ll
Send Email.. Save Cancel Delete User

Moving Users: T.takers can be moved from one user group to another by selecting the “Move Selected
to Folder...” button. In the example below, we have 1) ctrl + clicked to select three user profiles from
user folder “Group-1” and then 2) clicked the “Move Selected...” button. This launches a “Choose a
Folder” window displaying the various t.taker folders.

Users
| Move Selected to Folder.. i?l [Choosea Folder < 3

iddle

Last

w0 Group-3
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To move the t.takers from the Group-1 folder to the Group-2 folder, we select the Group-2 folder and
click the Ok button.

Choose a Folder

Test Takers
; Group-1
w0 Group-3

0K | Cancel |

These users are then added to the Group-2 folder.

& Ella Fain
Courses and Tests Use rs é
Bl Reports
H Question Bank Maove Selected to Folder f
& Media Bank
=48 Users
Instructors Zoe Celeste aceleste
= Test Takers guestl guesti guestl
Group-1 guest3 guest3 guest3
guests guests guests
Group-3 Patti [ Hamby phamby
Administrators Asa Lyons afain
2 System

W“Jw oy

%

T.takers, as well as Instructors and Administrators can be moved from one (like) folder to another.

For example, if Instructors and Administrators are organized into sub-folders, the t.admin can move
these user-types into like folders.
Enrolling Test Takers in a Course

Under the older TG2.4.16 user interface, when enrolling t.takers into a course, they appear as folders
under the “All Test Takers” column.

)

Enrolliment | Instructors ] Motes ]

All Test Takers
Test Takers

@09 Group-1
@03 Group-2
@ Group-3
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Individual users in a group can be selected and added to a course...

Enroliment | Instructors I Notes |

All Test Takers
% Test Takers
{3 Group-1
= Group-2
B Group-3
e N Aurcioch, Iris |

ok Peez. Warren (123456785)

5k Shariff. Rahirm (123456751)
-doh Transmshar, Manny (123456784)

... or the entire group folder can be selected, adding every user under that folder into the course.

Enrollment | Instructors | MNotes |

All Test Takers

" TestTakers
-0 Group-1

-0 Group-2 P Add >>

=% Group-3
<< Remove |

-{oh Murdoch, Iris (123456783)

-Gk Pesz Warren (123456785)

-5k Sharifl. Rahirm (123456781)

{5k Transmshar, Manry (123456784)

Enrolled in this Course

\MM

New User Interface

Last | First | Username
Murdoch Iris im

Peez Warren wp

Shariff Rahim rs
Transmshon Manny mt
Zhu Matt mz

The revised control displays the enrollees in a single table, below.

Course (
Code: |Course—1

Session: Summer

Days: MWF

Time: &AM - 10 AM

Description”  |Sample course configuration

Internal ID: 23

| Enrolment instructors | Notes |

Last | First | Username D E |
Murdoch Iris im 123456783
Peez Warren wp 123456785
Shariff Rahim rs 123456781
Transmshon Manny mt 123456784
Zhu Matt 123456780

b
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The Add button at the bottom of the Course window...

Add Remave |

... enables the t.admin to 1) type in a search parameter, hit Enter or click 2) Find.

Search results are displayed in a table, below (3). .

Find User
Last Name: |Bryden First Name:
User ID: Primary ID:
Folder:
e 1<2) ‘
Double-click o edit 1 User(s) Found

Email

Cancel

Editing a User Profile: The t.admin double-clicks on the t.taker row to edit the profile....

~

User - Test Taker

S,
Last Name:  |Bryden | Disable User (Use the View menu fo show these users)
First Name:  [Bill [~ Disable Login
Middle:

| Scores : Login | Pelsonall Perrmsslons| Nolesl

Use only letters and numbers for the User ID and Password, with no spaces

User ID: |bD
Current Password

Blank Password? [

New Password:

[ user must change password at next logon

Send Email... Save Cancel Delete User
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Adding a User to a Course

... or select the t.taker (row) and click the 4) Select button.

-

Find User
Last Name: Iawden < 1 First Name: I

User ID: | Primary ID: |

Folder: _l

2
Double-click to edit

1 User(s) Found

Last Name First Narme User D

This will add the user to the Course.

Enroliment | Instructors | Notes |

Last | First | Username ID

Bryden Bill bb 123456782
Murdoch Iris im 123456783
Peez Warren wp 123456785
Shariff Rahim rs 123456781
Transmshon Manny mt 123456784
Zhu Matt mz 123456780
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Locate Users by Folder
Another selection option is the “Folder” button. When clicked it...

Find User

Last Name:

User ID:

Folder ||

... launches a separate window displaying the available user folders:

Choose a Folder

|

The most recent interface enables the t.admin to select a group folder + OK. This then displays the 1)
selected folder name to the right of the Folder button. In order to display the users in the folder the
t.admin needs to click the 2) Find button, which displays the users in a 3) table.

User ID: I Primary ID: I

Folder: | Gro@

Double-click to edit

5 User(s) Founc

Last Mame First Mame
kurdach 123456783 !

Feez 123456785 4048764699 wiBorg.com
Shariff 123456781 E789903345 ri@arg.com

Transmshon kanny 123456784 4048887777 m@ory.com
Zhu W adt 123456780 4045760095 m@org.com
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Under this interface, the t.admin can select a single user, or shift + click to select a group of users or ctrl
+ click to select a non-sequential list of users.

The t.admin can also dbl-click on a row to display the User profile window, enabling the t.admin to
review t.taker scores, etc.

User - Test Taker

Last Name: | [~ Disable User (Use the View menu to show these users)
FirstName: |Philippe [ Disable Login
Middle: |

Internal 1D: 330

Scoresl Logln] Personal I Permlssmnsl NOIESI

Test [ Date Taken | Score % | Attempt
4/7/2011 1:48:57 PM 31.33/56 5595 1

2/18



% TG Tutorial: Enrollment

Course Enrollment and Eligibility
Scenario 1

In this example of the older TG2.4.16 user interface, when t.takers are added to a course they are — by
default — automatically enrolled in any tests that have been created under that course, IF the "Test
takers enrolled in the course...." checkbox is enabled:

[» Students enrolled in this Course are automatically enrolled in all tests / surveys for this Course

And, by default, their enroliment date is the current (system clock) date and time. At that point, they
become eligible to take any active test under that course. In this example, Bryden Celeste and Hamby
are enrolled in Course 1.

(& Ella Fain
= Courses and Tests CO urse
L Course- 1]
- Test-1 Code [Course-1
[ Test-2 3 —
ession
[ Test-3 Summer
[ Test-4 Days: MWE
[ Test5 T —
ime R
8 Course-2 BAM-10AM
Course-3 Description:  |[Sample course configuration
Course-4
=@ Course-5 Internal ID: 23
@ isgéH‘VE Enroliment
-F Question Bank All Test Takers Enrolled in this Course
& Media = Test Takers Last [First [ Username
-8 Users £ Group-t Bryden Bill bb
& My Account £ Group-2 Add == Celeste Zoe aceleste
3 System £ Group-3 Hamby Patti phamby
<< Remove
o ] b
[ Test Takers enrolled in this Course are automatically enrolled in all tests / surveys for this Course

Bryden, Celeste and Hamby are also automatically enrolled in every test under Course 1.

[ Ela Fain T
56 Corses and Tests est
& @8 Course-1
Y T | Name: Test1
3 Test:2 e
Test3
Test4 Description Test description here
) Test5
= @ Course-2
= @ Course-3
“ourse? internal ID:
= @8 Course-4
B oS ctoton| Scomes| Sty WesiTeks
2 Reports All Tast Takers enrolled in this Course. \ Test Tekers eligibile fo take fis Test
B Quaston Bank = [Fist (] ot Fist [Usemame [ Eigie
Hedia Bryden Bill b Bryden Bl bb 212013916 00 A
@ Users Celeste o aceleste Celeste Zoe aceleste 211201281610 A
£ My Account Fain Ela Bdmn Hamay Patt phamby 21112013 91608 A
= i System Hamby Path phamby
Add =

<< Remove

Eigtls =] [ Monday . February 112013 <] [9.16.14 AM 2]
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Date and Time

Date and time settings will vary based on which TG product you are using:

. TG Desktop: t.takers enrollments are based on the t.admin’s computer date/time.

. TG LAN or TG Web customers: enrollments are based on the server’s date/time.

. The specific date/time is defined by the calendar/time settings that appear at the bottom of the “All
Test Takers enrolled in this Course” column which appears at a test level.

Eligible | | Tuesday . February 12, 2013j |5:05:11 PM =

-

By default, this setting displays the testing system’s current date and time. To refresh the time, press
the F5 key or the green Refresh icon in the icon toolbar:

File Edit Tools View Help
NEFEHITBASI X 2PN

ez~
=

Scenario 2

T.takers enrolled at a course level are NOT enrolled in individual tests under that course
. IF the "Test takers enrolled in the course...." checkbox is UNCHECKED

[ Students enrolled in this Course are automatically enrolled in all tests / surveys for this Course

Consequently, they are not eligible to take an active test until the t.admin enrolls them at a test level.
Unless a different enrollment date is specified under the Eligibility date/time setting, they are — by
default -- enrolled based on the current (system clock) date and time.

The Eligibility date/time setting defines when t.takers are granted permission to take a test.

Under this process, t.taker enrollments can be staggered, allowing t.admins the option of enrolling
individual t.takers, or groups of t.takers, at various (future) dates and times. In the example below,
Hamby’s test enrollment has been shifted to a later eligibility date, so even though she is enrolled in the
test, she won’t be able to take it until March 11, 2013.

Test Takers eligibile to take this Test

Last First | Username | Eligible
Bryden Bill bb 2M11/2013 91614 A
Celeste Zoe aceleste

Hamby Patti phamby
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Un-enrolling and Re-enrolling a Test Taker

At a course level, a t.taker can be un-enrolled by 1) selecting/highlighting the t.taker’s last name and
then 2) clicking the “Remove” button. The t.taker (3) can be re-selected if/when the t.admin wishes to
re-enroll them in the course.

Enroliment l Instructors l Notes l F
All Test Takers

ourse
E:j Test Takers - First | Username
= Group-1 Bill bb
-5k guestl, guest (000-00-0001 Zoe aceleste
(o Quest?. guest? (000-00-0002 Patti phamby

)

)

-k guestd guestd (000-00-0003)  |= I
b guestd, 00-0004) << Remove

- {ch Quests, 3 00-0005)

B Group-2

-k Bryden, Bill{123456782)
--fch Celeste, Zoe (123456787)
-k Harnby, Patti M1 (123456789)
-k Lyons, Asa (123456788

M TCeminsd

i
M\.ﬁ*ﬁ g n

At a test level, a t.taker can be un-enrolled from individual tests without affecting their course
enrollment. In the example below, 1) Bill Bryden has been un-enrolled from 2) Test 1.

|5 Ella Fain L
--3 Courses and Tests TeSt
=@ Course-1
B Test1 < 2 I Name: Test-1
[ Test-2
|4 Test-3
[ Test4 Description Test description here

|4 Test-5
& Course-2
& Course-3

Internal ID: 248
@ Course4
@ Course 5 Activation | Scores| sh Test Takers |
B ARCHIVE ivation | Scores| Sharing
& Reports Bank All Test Takers enrolled in this Coursa Test Takers eligibile to take this Test
i uestion Banl
) g Sled\a Last [ First | usemame | Last First | Username Eligible
Bryden Bill bb Celeste Zoe aceleste 2/11/2013 9:16:10 A|
-+ Users Celeste Zoe aceleste Hamby Patti phamby 3/11/2013 4:43.03 A
- My Account Fain Ella Admin
- System Hamby Patti phamby
RS VNN Fo L g gpin, g » '—-"‘—‘.“‘»’LW”‘

He continues to be “enroll-able” from the “All Test Takers enrolled in this Course” column, but he is not
eligible to take Test 1. IF the Course property “Student enrolled in this Course...” were checked at the
time he was enrolled, then he remains enrolled in Test 2 through Test 5 until and unless the t.admin un-
enrolls him from any of these tests.

[v Students enrolled in this Course are automatically enrolled in all tests / surveys for this Course

2/18



% TG Tutorial: Enrollment

T.takers can be un-enrolled from the "Test Takers eligible..." column on the right

To un-enroll a t.taker, select/highlight the t.taker’s last name and then click the “Remove” button

To re-enroll a t.taker in a test, select/highlight the t.taker’s last name in the “All Test Takers enrolled in
this Course” column and then click the “Add” button, the re-enrolled t.taker will appear in the “Test
Takers eligible...” column.

Al:tivation] S:ores} Sharing TestTﬁRe

All Test Takers enrolled in this Class Test Takers el

Last | First | Username

Anthony Susan guesti Anthony
Apgar Virginia guests Apgar
Galois Evariste Admin Galois
Minoka Lillie guestd Minoka
Pelletier Marie guest3 Pelletier
Potter Beatrix guest? Add == Potter

<< Remove

<|—'

[Eligible | | Sunday , February 10,2013j |6:43:52AMj| ?

From the “All Test Takers enrolled in this Class” column:

a- Anindividual t.taker can be selected and enrolled
b- Multiple t.takers can be added by shift-click selecting a sequential group

Au:tivationl Su:c:res] Sharing TestTakersl

All Test Takers enrolled in this Class 1
Last | First | Username
Susan guesti
Virginia guests
Evariste Admin
Lillie guestd
Marie guest3
Beatrix guest2 Add ==

<= Remove

Eligible | | Sunday , February 10, 2013j |5:43:52 AM _*

-
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Two or more non-sequential t.takers can be enrolled by Ctrl-clicking selected t.takers from the list of
t.takers under the “All Test Takers...” column:

Activatin:unl Sl:l:uresl Sharing TestTakersl

All Test Takers enrolled in this Class

Last | First | Username
Susan guesti

Apgar Virginia guests

Evariste Admin

Minoka Lillie guestd

Pelletier Marie guest3

Beatrix guest2 Add ==

If a t.author mistakenly enrolls a t.taker on the wrong date/time:

there is no Undo command — the t.admin must select the t.taker and click the Remove button.

TG: Enrollment Review
Test administrators are now able to review enrollment through a separate interface.
This feature is located under the “Edit” menu on TG’s home page:

@ Test Generator

File | Edit Tools View Help
& @ Find Ctrl+F
Al Z PP Find Next F3
ﬁ Find User

va Enrollment

Test administrators are provided with the following options:

e Export the search results

Select All or De-Select All of the results in the table

Modify the enroliment date and time

e Modify the enroliment time only and then Update the records
e Delete to un-enroll a test taker from a course or specific test.
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TG: Enrollment Review

This feature can be accessed from TG’s home page by selecting File > Enrollment. This will launch the
enrollment window. This feature was added in order to make it easier for test admins to view and
modify enrollment information by Test Taker, Class or Test. Rather than having to select individual
courses and tests to discover enrollment information, the Enroliment feature makes it much easier to
quickly view and update enrollment information on an as-needed basis.

In the example below the test admin chose to search by Class and typed in a class named Logistics and
pressed the Filter key. This action populated the display with a list of individuals enrolled in tests that
are saved under the Logistics class.

Enrollment

First: Last: | Class: | Logistics Test: Filter

First Last ] Usemame | Class Test Enrolled

Total number of records: 1608 Export

Select Al De-Select Al l | Thursday , May 09, 2013j |9.08:40 AM = [Date / Time v | Update Delete Close

2/18



% TG Tutorial: Enrollment

Search

Test admins have the option of searching by 1- First or 2- Last Name, by 3- Class or by 4- Test
This feature makes it easy to identify which Class and Tests an individual user is enrolled in.

Enroliment 1 [7 ’%ﬁ [T
First [ = D Last: I%-— Class: Test Iﬁ Filter

|F|rst |Last \Usemame |Class \Test |Enr0Hed -

'

Two or more parameters test parameters can be searched. For Example, if | wanted to find out how
many tests Georgia was enrolled in by Class, | could type in her last name and the Class | want to look at.
This would display all classes that Georgia was enrolled in, under that Class.

Eligibility

Test admins can modify 1- the Date, 2- Time, 3- specify Date/Time or Time Only, 4- Update changes
based on the records selected from the results table above and 5- Delete which removes any individual
or group of individuals that are highlighted in the table above.

| - _ ot
Total number of records: 364 Export 1 2 3
|
Delats Close |

Z
Selact Al De-Selact Al | | Thursday . May 09, 2013j I?:34:15AMj| |Dete’y Time |

— — —— Time Onlg

Update

Export

The search results can be exported to a .csv file. This file can then be opened in Excel.

Scheduling Module

Another feature and set of properties that will influence a t.taker’s access to tests is the Eligibility
module which is located under Test Settings > Test Properties: Schedule tab: Eligibility.

Scheduling-Eligibility Tutorial

We hope you found this information useful. Your comments/suggestions are welcome.
Please contact us.

Thank You
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