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. TG Scan

TG Scan is an add-on utility for Test Generator that facilitates importing test answer-
sheet data into TG’s database.

Scanners and Answer Sheets

TG Scan is hardware independent and will work with scanners that support the TWAIN
Specification 1.9. This includes scanners with Automatic Document Feeders (ADF) or
simple flat bed scanners.

For more on TWAIN visit

An answer sheet is included with TG Scan -- you do not have to purchase answer forms —
a plain paper answer sheet will work.

TG Scan’s installer will place a copy of the form under C:\Program Files\Test
Generator\Admin\Upgrades. The file is called form_1.doc.



http://www.twain.org/
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Header and barcode
Student ID: 9 numbers.
Test Number: up to 5 digits
Date: mm/dd/yy

Responses: 100
Note: the squares in each corner are

orienting points required by the

scanning software.

A sample of the form_1 answer
sheet is displayed on the right
1)

2)

3)

4)

5)



. Printing

Ideally, the answer sheets should be printed on a laser printer. Printer Settings:
e Layout: Portrait

* Paper type/quality: Plain

e Color: Black & White

e Print Quality: Best, High or at least 300 dpi

e Paper Size: Letter (8.5 x 11 in.)

We suggest printing a sample form and then scan the answer sheet into TG to ensure
that the image quality is acceptable.

Of critical importance is the barcode. TG Scan must be able to read the barcode. If the
barcode resolution is low, or if the entire bar code is not showing, then the answer
sheets will not read by TG Scan.

Acceptable

Not Acceptable
barcode incomplete




Using TG Scan




. Process

Step 1: Create, edit/evaluate a test in Test Generator.
Step 2: Activate the test (Test Settings > Test Properties > Activation tab).

Step 3: Enroll test takers in the Class (Course) under which the TG test was created.
Assumption: at this stage, the test taker profiles have been created or imported into TG.
Note: A test taker must be enrolled in the course in order for their test results to be
scanned into the test created in Step 1.

Step 4: Print the test.

From an open test, File > Print Questions or...

File > Print Preview > Questions. You can save the print preview to a text (*.txt) file or
an rtf file. Option: the test can then be opened/edited in a word processor if you wish
to add other text enhancements to your test.

Important. Do not alter the test content in any way (question/answer text, number of
guestions/answers). If you need to modify the test, modify it in TG, and then save
(Save As) the test before adding any text enhancements.




. Answer Sheet: Student ID

Step 5: Test takers will fill out the Answer Sheet. Test takers will fill in the Student ID.
The Student ID is a nine-digit string that is part of the test-taker’s User Profile in TG. The

Test # and Date are both optional.

User

. [Munguia User Type
Last Namne ;: e
First Name: [/058 " Instructor
Middle: Maria & Student

Scoresl Login Personal IPermissions I Notes |

Address: 460 N. West St
City: Nogales
State: AZ
Zip: 85821
Phope- =~ ~ =~
UL ~
, S N
( PrimaryD:  [001122334 !
4
-

~
Secengary ID:

Student ID
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|~ Disable User (Use the View menu to show these users)

Detail from TG User Profile Detail from Answer Sheet




Sample Answer Sheet
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: Your test takers will read the

test questions and then fill in the
appropriate answer box on the

answer sheet.

5 represents hundred thousands

5 represents hundreds
5 represents thousands

5 represents tens
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What value does the & digit have in the number 5,280?
Printed Test (detail)
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Scanning Answer Sheets

Once the test has been completed and the test and answer sheets have been
collected, the Answer Sheets can be scanned into TG.

The Answer sheets are placed in a sheet feeder. Next, open TG and select the
appropriate test in the tree view (1). Also, notice the Scan Results button (2) at
the bottom of the window. Press the Scan Results button.

E;iurGjeorge Bennett Test

Classes and Tests

.. GampleTest 1 Name: Sample Test

@ Sample Class Description:
@ ARCHIVE
7[5 Reports
=2 Question Bank Activation Shalingl Sludenlsl

-7 Media
€3 Users Students Scores

@99 System [Lest ~ [Fit [  DateTaken| ObjScoe| EssayScore| |

Scores window for
“Sample Test”.

Score Essay I Rescore Test Certificate I Scan Results | Delete I

Test Generator tree view




Process

TG will prompt you for a Test Number.

Enter the number that appeared on the printed test.
In this exercise, enter any four-digit number you wish.
Next, click the OK button to view the TG Scan Test Information screen.

Test Generator

Please enter the Test Number corresponding ta this
batch of response sheets.

'~ Test Information

Class:

Cancel I Name: Sample Test
Number: 1234

Total Points: 10
Description:

01 23 Summary Current Student

Response | Scare Max Pts
001122334
001122335
001122336
001122337

Test Information Screen




Process

Select File > Import From > Scanner...

%’F_'e ...this will display a Select Source
| TN

(B sovescores  cws 9B ke window and the active scanner.
Exit Ale+F4
Name: Sample Test
Number: 1234

Total Points: 10

Description:

Select Source

Sources:

Jose 001122334
James 001122335 Cancel I
Timathy 001122336
Warren 001122337

Click Select to begin
scanning the Answer Sheets.




Process

Once an answer sheet has been scanned in successfully, the test-taker’s results
will be displayed in the Test Information screen.

H File

[CIEE
Test Information
Class:

Name: Sample Test

Number: 111

Total Points: 10

Descrigtion Test results and scoring appear in the

Results table, below.

Summary Current Student———————————————
Class Avg: 8 Name: Jose Munguia ID: 001122334 Score: 8

Roster

Last First 1D Processed? | Score Response |Score
Munguia  Jose 001122334 v
Bennett James 001122335
Kane Timothy 001122336
Peez Warren 001122337

The “Y” in the Processed? column
indicates that Jose Munguia’s results
have been imported.

mOFrmEoOFO0®o>
P FErY PG PG G NG P P S




Saving Results

Once the answer sheets have been scanned in, save the results by selecting the
menu item, File > Save Scores, or by clicking the Save Scores icon in the toolbar.

This will record the test results to TG’s database and a
summary view of these results will be visible under the

MName: Sample Test
Test’s Scores tab.

Number: 1234
Total Points: 10

s Activation SCOIESI Sharingl Studenlsl
Description:

Students Scores

m-ﬁﬂl

S (el Jose 7/25/2005 5:44:27 ...

Scores tab (detail of imported test




Answer Sheet




. Answer Sheet

The TG Scan answer sheet (form_1.doc) is the only answer sheet provided in the
evaluation copy of TG Scan. Other answer sheet formats can be created. Please
contact us with your requirements.

XML Parser

In order to run TG Scan, you will need to download and install Microsoft’s XML Parsing
Utility:

Supported Operating Systems: Win 2000, Vista, Win 7 and 8#



http://download.cnet.com/Microsoft-XML-Parser-MSXML-3-0-Service-Pack-7-SP7/3000-7241_4-10731613.html
http://download.cnet.com/Microsoft-XML-Parser-MSXML-3-0-Service-Pack-7-SP7/3000-7241_4-10731613.html
http://download.cnet.com/Microsoft-XML-Parser-MSXML-3-0-Service-Pack-7-SP7/3000-7241_4-10731613.html
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Header and barcode
Student ID: 9 numbers.
Test Number: up to 5 digits
Date: mm/dd/yy

Responses: 100
Note: the squares in each corner are

orienting points required by the

A sample of the form_1 answer
sheet is displayed on the right
scanning software.

1)
2)
3)
4)
5)




The document, form_1.doc, header contains graphic and text elements.

Header -Section 1-

1>CUSTOM TITLE — 1 LINE

2> SUBTITLE -1 LINE
PLEASE ENSURE HEADER SIZE STAYS THE SAME <3

Header text elements

1- CUSTOM TITLE - 1 LINE -- Arial, 18pts, centered

2- SUB TITLE - 1 LINE -- Arial, 10 pts, centered

3- PLEASE ENSURE HEADER SIZE STAYS THE SAME -- Arial, 10 pts, centered

Header graphic elements
4- Two orientation blocks/squares — Height: 0.25“, Width: 0.25”
5- Barcode — Height: 0.25“ Width: 2.01”, Lock aspect ratio, Relative to original picture size.




Form_1.doc’s footer also contains graphic and text elements.

1> Page1of1
2 > CUSTOM FOOTER GOES HERE

3 > PLEASE ENSURE THAT THE HEIGHT OF THE FOOTER STAYS THE SAME

Footer text elements
1- Page 1 of 1 -- Arial, 8pts, centered
2- CUSTOM FOOTER GOES HERE -- Arial, 8 pts, centered

3- PLEASE ENSURE THAT THE HEIGHT OF THE FOOTER STAYS THE SAME —
Arial, 10 pts, centered

Footer graphic elements

4- Two orientation blocks/squares — Height: 0.25“, Width: 0.25”
5- One small block — Height: 0.16“, Width: .16”

Note: this block is not in the footer window. It is actually at page level,
positioned to the left of the right-most orientation block.




The Custom Description section of the Answer Sheet allows for 3 lines of text.
The style sheet is Interface Table Text, Arial, 10 pts.

CUSTOM DESCRIPTION — PLEASE ENSURE THAT THE SIZE OF THIS AREA STAYS THE SAME

Response boxes

The response boxes allow for up to 100 questions and includes five answer boxes, A
through E. The test takers will darken the answer box that corresponds to that
particular question.

Responses
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FAQ

Q: What is TG Scan (TGS)?

TG Scan is a software utility that works with Test Generator.
It facilitates the importation of test answer-sheet data into TG’s database.

Q: Does it require a separate installation?

Yes, TG Scan is packaged in an installer file: TG2_TGScan-r2.4.## Installer.exe

Q: Does TGS ship with a scanner?

No, TGS does not ship with any hardware. The assumption is that you already have a scanner
or plan on purchasing one.

Q: Do you recommend a particular type of scanner?

No. TGS is hardware independent and will work with scanners that support the TWAIN
Specification 1.9. This includes scanners with Automatic Document Feeders (ADF) or simple
flat bed scanners. For more on TWAIN visit



http://www.twain.org/

o

Q: What operating system is TG Scan compatible with?
TG Scan will work with Microsoft Windows 2000, XP, Vista and 7 and up.

Q: Are there any other components needed to run TG Scan?

You will need

Q: Which TG solutions support TG Scan?
TG Scan can be used with TG Desktop, LAN, or TG Web.

Q: Is TG Scan included with the TG Demo download?

No. TG Scan is a separate utility. For more information please or email
support@testshop.com.



http://download.cnet.com/Microsoft-XML-Parser-MSXML-3-0-Service-Pack-7-SP7/3000-7241_4-10731613.html
http://download.cnet.com/Microsoft-XML-Parser-MSXML-3-0-Service-Pack-7-SP7/3000-7241_4-10731613.html
http://www.testshop.com/contact

FAQ

Q: Which question types does TG Scan support?

TGS supports multiple choice, checkboxes and true-false question types.

Q: Do | have to purchase answer sheets from you?

No. TGS includes an answer sheet template. The template is included
with the TGS installation. For more details, please read the Overview
and Answer Sheet sections of this tutorial.

Q: Can the Answer Sheet be modified?

The header and footer text information can be modified per the guidelines
described under the Answer Sheet section of this tutorial. However, the basic
layout of the form should not be altered. This includes the orientation squares,
barcode, IDs or Response sections of the form..




FAQ

Q: Once the data is "captured” where is the data saved?

The test data is saved in Test Generator's database. In TG Desktop and TG LAN_msa,
the data is saved in a Microsoft Access database. In TG LAN_sql and TG Web,

the data is saved in a Sqgl database. The currently supported databases include:

MS SQL, MySQL and Oracle..

Q: Can this information be exported and viewed/edited in another format?

Yes, the report data can be exported into various file formats. This can be done by clicking the
Export button under the reports print preview window, and selecting from among the various
output formats available in the drop-down menu.

Note: while there are many formats presented, not all of them will display nicely formatted
information. PDF, CSV, Excel, RTF, Text and Word are a few that you may want to try. We suggest
experimenting with the different formats and choosing one that suits your particular needs.




FAQ

Q: Once the data is "captured”, where is the data saved?

Once the data is imported into TG, you can view the data using one of the following:

A- Under the tree view, select your test and then click the Scores tab on the right side of the
screen. This summary view includes LN, FN, Date, Score and Attempt.

B- Student scores report

C- Class scores report

D- Test scores report

E- Study Guide report

F- Question Reference report

For more detailed reporting information, select the Reports module in TG's tree view and click the
F1 key. This will display the contextual help topic, Reports Overview.




FAQ

Q: If I don't find the report I'm looking for, or if | would like the report data
presented in a different layout, what are my options?

If you are using TG Desktop or LAN and have the IT resources available to customize reports, we
would be happy to provide you with a data "map" that could be used by IT to generate reports in
MS Excel, MS Access or Crystal Reports.

If you are using TG LAN_sql or TG WEB, you have access to the data and can run Sql queries using a
report generator of your choice.

If you don't have the resources or the time, we can customize a report for you. We would need a
detailed description of what you want. Once we receive that information, we will give you a report
customization quote, and proceed with development once we receive signed authorization and a
down-payment.

We are available to discuss this with you in more detail at your convenience. , or email
support@testshop.com.



http://www.testshop.com/contact

. Thank You

We appreciate your review of this tutorial. We look forward to working with you.
Please let us know if we can be of assistance.

Support

If you experience any problems or need additional help please email
, or



mailto:support@testshop.com
http://www.testshop.com/contact

