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Your TG Desktop demo includes a Sample Class containing two tests. 
Each test has been activated and can be taken by logging in to the Tester application  
located under Start > Programs > Test Generator > Tester.  The windows Tester is used in TG Desktop 
and TG LAN. 
 
TG Web tests are delivered through a web browser. If you’d like to view a Sample Class test over the 
web, register here https://www.faincompany.com/demo/.  You’ll receive a follow-up email with login 
information, or contact us to schedule an online demo.  
 

In order to perform the steps outlined in this tutorial…  
• You have successfully downloaded the TG installation file from our web page:  
   http://www.testshop.com/free-trial-tgd .  
• You have successfully installed TG on your computer. 
• You can log in to TG and view the home page. 

Sample Class tests 

Background / Assumptions 

TG Introduction 
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If you wish to expand the Tester window, click the Maximize button in the upper  
right-hand corner of the Tester window (6). 

This is a sample screen from the windows Tester. 

The title bar (1) displays the test name.  
The toolbar (2) includes two navigation 
buttons, as well as Clear, QList, Help, 
Media, Font and Flag buttons. 
 
The yellow field (3) contains your question, 
and the answers (4) are displayed below 
the question field. 
 
The status bar (5) at the bottom of the 
Tester window, displays the elapsed time, 
the question # and the system date/time. 
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TG Windows Tester 



This is a sample test screen from the web Tester. 

The status bar (1) displays the test name, a real-time clock, the question #  
and the Time/Date stamp of the local computer.  The toolbar (2) includes two navigation buttons as 
well as Clear, Summary, Media and Flag Question buttons.  Below that, the question (3) followed by 
the answer choices (4).   
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TG Web Tester 





Open TG: Start > All Programs > Test Generator > Test Generator 

login to TG  

The username is Admin. 
The password is Admin. 
 
Press enter or click the Login button to open TG. 

TG Test Generator 





A Class – also referred to as a Course -- is a repository for one or more tests.  To create a Class, click 
on the Class icon on the toolbar… 

… or select File > New > Class from the text menu. 

Note: You can skip this step if you wish to save your test under the Sample Class 

TG Create a Course 



A dialog box prompts you to ‘Enter the name of the new Course.’   
Type in a name and click OK. 

Our new class icon appears in the tree view under Courses and Tests. 

Classes are containers under which you can create and save one or multiple tests. 
You can create and publish as many tests as you wish – at no additional charge. 

TG Name Your Course 



The right side of the screen contains course information. 

The top section (1) includes:  
• Course (Code) name and 
• Session. Days. Time and Description fields.   
 
Under the Enrollment tab, two columns:  
• All Test Takers (2) and  
• Enrolled in this Course (3) 
 
User Profiles 
Your TG demo includes five user profiles, guest1 
through guest5.  You can enroll one or more of these 
users in your course, and/or create your own test taker 
profiles. 
 

TG Course Information 



In order for your testing audience to take one or multiple tests, they must have a user profile 
in TG’s database and they must be enrolled at a course level.  For more details see TG Help > 
Contents > Enrollment. 
 
User profiles can be created manually in TG (File > New > User), imported using a TG-friendly, 
.txt, .csv or excel (.xls) file, or synched using our  optional, AD/LDAP plug-in. 
 
Enrollment Options 
Test Generator also supports other custom, user-registration methods. 
Please contact us for more details. 
 
 

TG Your Testing Audience 

http://testshop.com/contact.php




Open TG: Start > All Programs > Test Generator > Test Generator 

open TG 

login to TG  

Enter your User ID and Password. 
Press enter or click the Login button to open TG. 

TG Create a Test 



To create a Test click on the New Test icon in the toolbar… 

… or select File > New > Test from the text menu. 

TG Create a Test 



A new test template includes a standard text menu (1), icon toolbars (2), a series of 
tabs representing various question parameters (3), a question field with instructions 
(4) and an empty question table (5). 
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This initial view is referred to as a test’s summary screen. 

TG Test Template 



This is an example of the CPR test’s summary screen. 

TG Test Summary Screen 



The question field in your new test template includes instructions. 

Click the Add a New Question icon and select 
Multiple Choice from the pop-up menu. 

This icon can be found in the icon toolbar directly above the instructions. 

TG Create a Multiple Choice Question  



This is an example of the multiple choice question template.  The text in the question 
field is highlighted.  You can delete this text or simply type over it.  TG includes six 
methods for adding or creating test questions. 

TG Create a Multiple Choice Question  



Next, click the red “A” (Add Answer) icon. 

By default, this creates 
four answer fields below the 
question field. 

TG Add Answers 



If you want to add more answers, click the Add Answer icon again – you can up to  
10 answers per multiple-choice question. 

In this example the icon 
was clicked once to add 
a fifth answer field.  

Option: You can also right-click in the answer 
field to select from a list of options.  

TG Add / Remove Answers 



Type your answers into the question and answer fields. 

Next, identify the correct answer by selecting its corresponding radio 
button.  “C” in this example. 

TG Add Answer Text 



Apply a point value to your question.  The question points field is located above 
and to the right of the Question tab.  We’ve assigned “1” point to this question.  
Questions can be weighted. 

Next, save your test by selecting File > Save from the text menu… 

… or click the Save icon in the icon toolbar. 

TG Assign Points and Save Your Test 



In the Save Test window, name your test (1), 
select the Class that you want to save your 
test under (2) and click the OK button (3).   
This will save Your Test under the course,  
Your Course.  

1 

2 

3 

This process will create a test icon under 
Your Course in TG’s tree view. 

TG Save Your Test Under a Course 



Before your test can be taken, it must be activated.  From the text menu select Test Settings > Test 
Properties. This will display the Test Properties window and the General tab contents. 

Option: Select the Activation Dates toolbar icon 
to navigate directly to Test Properties Activation 
tab. 

TG Activate Your Test 



Activation properties are located under the Test 
Properties’ Schedule tab. 

Other test properties such as Time Limit, Retakes and Eligibility are best explored once 
you gain more experience with TG.   

They include a Permit Testing checkbox (1), and 
From and To date and time windows (2). 
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TG Activate Your Test 



The From and To activation parameters can be set broadly... 

… or narrowly – depending on your testing policies and practices. 

Note: A test is not active until you select/check the Permit Testing checkbox.     

TG Activation Parameters 



From and To calendar dates can be selected using the pull-down menu… 

… and the right and left arrow keys to select another date parameter. 

… or by highlighting the individual cells and clicking the up and down arrow keys on 
your keyboard to change the date settings… 

TG Activation Parameters 



Once the From (start) and To (end) dates have been selected, check the Permit Testing 
checkbox to activate your test.  

permit testing 

Note: Tests must be activated before they can be taken.  If you are not prepared to activate 
and evaluate your test, that’s fine.  You can continue to refine and activate it later. 
 
A test can be activated/de-activated as necessary.  If a particular test is only given one day 
during the month, you can activate the test to permit testing and then de-activate it by un-
checking Permit Testing.   

TG Activation Parameters 



This short tutorial illustrates the process of creating a test with one multiple choice question.  Your 
tests will, of course, contain more than one multiple choice question. 
 
Also, TG supports 10 additional question types as well as a multitude of question and test settings.  
For more test creation details please review: 

• TG Help > Quick  Start 

• All topics under TG Help > Tests > Test Authoring   

• All topics under TG Help > Creating Questions and Answers  

online demos and webinars 

We also offer online demos and webinars. To request a guided online demo go here: 
http://www.testshop.com/schedule-demo/ or call 928.266.0553. 
 

TG Creating Other Questions / Question Types  
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A test must be activated before it can be evaluated through Tester. 
To help minimize errors that might invalidate your test, we recommend:  

• Creating one or more Master courses and authoring your tests 
under a master  course.  These tests would only be accessible to 
the test author and any other admin-level users that are enrolled 
in the course.  
 
• Allowing other admin-level users/peers to log in to TG and 
evaluate your test at a test-edit level.  Assumption: they are 
authorized to view/edit your exam as a test author.  
 
• Allowing admin-level colleagues/peers to evaluate your test by 
logging in to the Tester and taking the test as a test taker.  

If changes are required, you can edit and correct your test before publishing it to your test-taking 
audience.  A second round of reviews is optional.   
 
For a more detailed discussion of this topic see TG Help > Index.  Type in “tests” and select the 
Evaluating topic, Tests – Review Before You Publish. 

TG Evaluating Your Test 



In order to take a test that has been activated, test takers must be enrolled at a course level.  If 
you create a Master course, your admin-level peers must be enrolled in the course in order to 
take/evaluate your test.   

In our example, the Admin user selected the course icon (1), clicked on the Trainers tab (2), 
selected Jane Austin under the Trainers column (3), clicked the Add button (4) to enroll this admin-
level user under the Managing this Course column on the right (5).  Jane Austen is now eligible to 
log in to the Tester and evaluate Your Test as a test taker.  
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TG Enrolling Evaluators 



Creating Trainer profiles and enrolling them in a course is optional.  
 
The one exception is the tier-1, Admin user.  The Admin user permissions allow this user to edit 
any test, or evaluate any active test through Tester. 
 
See TG Help > Contents > Users, Users Overview for more details. 

If changes are required following your evaluation, open TG and correct the test before publishing it 
to your test-taking audience.  Any additional test review/evaluation will depend on you and your 
organization’s testing policies.   
 
We recommend some level of review in order to minimize the likelihood of publishing a test that 
contains spelling/grammatical errors or errors of fact which might cause you to invalidate the test. 

important: revising/editing your Test 

TG Enrollment 



1- Create a Master Course – name it whatever you wish.  
 
2- Create a separate, production course.   
     In this example,  Course1.  
 
3- Create and save your initial test under the Master Course.   
     In this example, Your Test. 
 
4- Activate Your Test to make it available for evaluation.   
 
5- Log in to the Tester to evaluate the test as a test taker.   
    TG Desktop and TG LAN reviewers log in to a windows    
    Tester.  TG Web reviewers log in to the web Tester.  Optional:   
    Enroll admin-level users in the  Master class.  Have them take  
    the test and provide feedback to the test author. 
 
6- Following the evaluation, the test author edits the test and   
    makes any necessary corrections.  Note: It is very important   
    to make these changes prior to publishing the test to your   
    test-taking audience.  If a test is changed after it has been  
    given, you run the risk of corrupting your test data.  

Recommendations 

TG Test Review & Publishing 



7- Once the evaluation process is complete, open Your Test and   
    save a copy (File > Save As) under your production course.   
    In our example, Course 1 is the production course. 
 
We’ve saved a copy of Your Test under Course 1 and renamed it C1T1 
(course 1, test 1) – you can name your test whatever you wish.  Test  
takers enrolled in Course 1 will be eligible to take the C1T1 test 
whenever it is activated by the test author. 
 
For a more detailed discussion we recommend reviewing all of the 
topics found under TG Help > Contents > Tests. 
 
Note: The steps outlined in this summary are recommendations. We 
encourage you to adopt testing policies that work for you. 
 
If you have questions, or would like to discuss the topic in more detail, 
please contact us. 
 

Recommendations 

TG Test Review & Publishing 



Recommendations 

You have…  
• Created and activated your test.  
 
• Logged in to Tester and evaluated your test as a test taker.  
 
• Edited your test, possibly taken it again and made more changes. 
  
• Determined that your test is complete and ready to be taken by   
  one or more members of your test-taking audience.  
 
• Made a copy of your master test and saved it under what we are   
  referring to as a production course.  
 
If you haven’t already done so, you’re ready to import/add users and 
then enroll them in your course. For a more detailed discussion about 
importing, adding and enrolling test takers we recommend reviewing 
TG Help > Contents > Users.  
 
We also support AD/LDAP and other registration options which we’d 
be happy to discuss with you – please contact us. 

TG Test Review & Publishing 





Your TG Desktop demo includes a Sample Class containing two tests. 
Each test has been activated and can be taken by logging in to the Tester application located under 
Start > Programs > Test Generator > Tester.   
The windows Tester is used in TG Desktop and TG LAN. 
 
TG Web tests are delivered through a web browser. If you’d like to view a Sample Class test over the 
web, register here https://www.faincompany.com/demo/.   You’ll receive a follow-up email with 
login information, or contact us to schedule an online demo:  
http://www.testshop.com/schedule-demo.  

In order to perform the steps outlined in this tutorial…  
• You have successfully downloaded the TG installation file 
   from our web page: http://www.testshop.com/free-trial-tgd.  
• You have successfully installed TG on your computer. 
• You can log in to TG and view the home page. 

Sample Class Tests 

background / assumptions 

TG Take a Test 
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Login as guest1, the user ID and password are the same.  
There are five guest user profiles you can use, guest 1-5. 

Open Tester: Start > Programs > Test Generator > Tester. 

login 

open Tester 

TG Tester 



Note: Both tests are set to Unlimited Retakes, meaning you can take each test as many 
times as you wish.  Clicking OK will take you to the first question in the CPR test.  

Select either the CPR or Math Sampler tests and click OK. 

TG Take a Test 



If you wish to expand the Tester window, click the Maximize button in the upper right-hand corner of 
the Tester window (6). 

The first CPR test screen, windows Tester. 

The title bar (1) displays the test name.  
The toolbar (2) includes two navigation 
buttons, as well as Clear, QList, Help, 
Media, Font and Flag buttons. 
 
The yellow field (3) contains your question, 
and the answers (4) are displayed below 
the question field. 
 
The status bar (5) at the bottom of the 
Tester window, displays the elapsed time, 
the question # and the system date/time. 
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TG Windows Tester Screen 



Back – navigate to the previous question* 
Forward – navigate to the next question 
Clear – clears your answer, select or re-enter a new answer 
Q-List – navigate to a table listing all of the questions in the test* 
Help – tester help 
Media – display media in a separate window*  
Font – increase or reduce the size of the presentation font 
Flag – flag a question for review prior to test submission 

(*) The availability of these buttons is determined by which test properties are  
enabled or disabled during test creation.  For example, if the test author does not 
want test takers navigating to a previous question, they can enable the Forward Only 
test property which disables the Back and Q-List buttons. 

TG Windows Tester Toolbar 



This is a view of the CPR test as presented in the web Tester. 

The status bar (1) displays the test name, a real-time clock, the question #  
and the Time/Date stamp of the local computer.  The toolbar (2) includes two navigation buttons as 
well as Clear, Summary, Media and Flag Question  
buttons.  Below that, the question (3) followed by the answer choices (4).   
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TG Web Tester 



Selecting an answer will vary based on the question type.  In this windows Tester example, an 
answer is selected by clicking on the answer, or the radio button next to the answer.  Test takers 
can change their answers by clicking on another radio button.   

TG Selecting an Answer 



Test takers navigate from question to question, or, if enabled, they can click on the Q-List button to 
view all of the test questions.  In this example, questions that have been answered are displayed in 
blue and unanswered items are displayed in red.  Also, this test taker has flagged question #3 – note 
the icon under the Flag column.   

TG Summary Screen 



In this example, a test taker can navigate to question #8 by double-clicking row 8 in the summary 
screen table.  Also, a test taker can navigate back and forth between individual questions and the 
summary screen, or navigate from question to question by clicking the Forward button in the Tester 
toolbar. 

The objective, of course, is to answer every question.  Once the test taker is ready to submit their 
test for grading, they click the Finished taking Test button in the bottom right-hand corner of the 
summary screen.   

TG Summary Screen 



TG automatically grades any objective question type and stores the results in a database. 
In TG, essay questions are scored by the test administrator.  See TG Help’s Scoring Essay Questions 
for more details.  

grading 

test results and the database 

Test authors/administrators can access and view test results by selecting the TG Reports module. TG 
Reports contains more than 20 report types.  Reports can be displayed, printed or exported into 
various file formats.  In addition to the standard reports, we provide report customization.  Please 
contact us for more details. 
 
For an overview of the various reports, select (highlight) the Reports icon and press F1 to open the 
Reports Overview topic. 

reports 

In TG Desktop, test results are stored in a run-time version of MS Access.  TG LAN test results can be 
stored in either MS Access or a Sql database.  TG Web test results are stored in a Sql database.   

TG Grading, Test Results and Reports 



 
 

Thank you for viewing this presentation. 
  We look forward to hearing from you. 

 
 

928.266.0553 
 

sales@testshop.com 
 

support@testshop.com  
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